WP Wrapper – Plugin

We’re happy to announce the release of wrapper for wordpress plugin

Plugin Name: WP Wrapper

Download Link: WP Wrapper on WordPress.org | WP Wrapper on GitHub

Wrapper for WordPress does a simple thing, adds a wrapper to your WordPress.

Joomla comes with built-in wrapper which is missed in WordPress by many wordpress users.

Options in admin panel include:

  • http or https (for secure browsing)
  • desired url
  • select page on which wrapper has to be shown
  • height
  • width
  • show scroll bar or not
  • show border or not

Up coming version will have many more options

Screenshot

screenshot-1

== Installation ==

1. Upload wp-wrapper folder to the /wp-content/plugins/ directory
2. Activate the plugin through the ‘Plugins‘ menu in WordPress
3. Goto: Settings > WP Wrapper to configure the plugin

== Frequently Asked Questions ==

= Can we show wrapper on multiple pages =

Yes, coming soon in next version

= What about using short code? =

Currently short codes are not supported. Later versions will include option to generate and add short code

== Screenshots ==

1. screenshot-1.png

== Changelog ==

= 1.2.1 =
* Fixes PHP notice issue
* WP 5.1.1 compatible now

= 1.2 =
* WP 5.0 compatible now

= 1.1.8 =

* WP 4.7 compatible now

= 1.1.7 =
* fixed fatal error on older versions of PHP under 5.3

= 1.1.6 =
* security update
* added nonces
* added capability check
* added sanitization check
* changed default url
* wp 4.5 compatible now

= 1.1.5 =
* security update
* wp 4.4.2 compatible now

= 1.1.4 =
* wp 4.2.2 compatible now

= 1.1.3 =
* wp 4.0 compatible now

= 1.1.2 =
* wp 3.7.1 compatible now

= 1.1.1 =
fixed bug – showing wrapper on non-selected pages

= 1.1 =
Added http / https option for secure websites
Minor performance improvement

= 1.0 =
Initial release

Download Link: WP Wrapper on WordPress.org | WP Wrapper on GitHub

hire best wordpress php css developer
Need Help? Hire me now!
I can help you in anything related to webdevelopment, including: HTML, CSS, PHP & MySql, WordPress (plugins & themes development, others), regular expressions, server management, etc.

44 comments on “WP Wrapper – Plugin

      1. Hi,

        Can you tell me please when you have a update available with multiple wrappages possible?

        I like to hear from you,

        regards
        Wim

  1. Hi,

    Plugin doesn’t work. I install it and setup all correctly but on the page which I select there is no url which I have define in settings.
    Do you have any idea what can be the problem?
    I use it on WP 3.2.1

    thx

  2. Works great, easy to use… but cannot handle https:// though, which is what I need.

    Any particular reason? Any hope of fixing that soon?

  3. Great Plugin….Sucks if you need multiple wrappers, in which I know of no case where would need only one. Its great to test but has no real use without the very minimum basic…”add another wrapper” link. The ease of use is outstanding. The install is outstanding. Everything else is Absolutely Perfect. One piece of advice, Every-time someone updates a plugin or try to make it better, they end up messing it up. Please please please, add multiple wrapper capability in its own stand alone version, and than make your new version with all the bells and whistles. Right now it works well (Except for the single wrap problem) and is very well written, takes very little effort to execute and most importantly works well with almost every single Theme out there. Great job well done to the Author. Keep me posted please.

    April Hawk

    1. thanks for your comment April.

      The multi page option will soon be available in next release

      however, it will ask the user to add “shortcode” in posts, e.g: [nurl=domain.com]

      this might make it bit less “easy to use” for some users, what do you suggest?

  4. I am unfortunately unable to get this to work correctly. I’ve set the specific page that I want the wrapper on in the settings however the wrapper then displays on every single page in the site. Is this a known problem or something goofy in my WP setup?

    1. Thanks for pointing out Lawrance, it was a minor glitch in the version 1.1 rolled out today.

      I have fixed it and rolled out 1.1.1

      If wp don’t give you upgrade option immediately please delete the previous one and download a fresh copy of the plugin.

  5. Wrapper works great, but I need to be able to have multiple wraps in order to make the plugin useful to a site. Thanks and great work!

    1. Thanks for the feedback and bug report. Can you please tell me:

      Your WordPress version
      Plugin version (update it to latest please)
      Chrome version
      Operating system
      Website url where you’re using it.

      Thanks.

  6. Member
    Posted 4 days ago #

    I have used plugin WP-Wrapper in several sites for several years. (Great plug in!)
    It recently stopped working in all of my sites, essentially crashing the sites. The following error is generated when navigating to the sites:

    Parse error: syntax error, unexpected T_FUNCTION in /home4/gkscott/public_html/ngafmmf2/wp-content/plugins/wp-wrapper/wp-wrapper.php on line 87

    I can get the sites running again by deleting the plug in (WP Wrapper) via FTP, but when I try to reinstall WP Wrapper, I get the same error in the Admin panel when I try to activate WP Wrapper again?

    Any help will be greatly appreciated!

    1. Please tell me:

      Which version of plugin you’re using?
      Which version of WordPress are you using?

      This happened when you updated the plugin? or Updated WordPress? or any other change?

      1. The issue was due to your server using older version of PHP (under 5.3) while the plugin used a feature of PHP 5.3+

        However I’ve modified the code to be compatible with previous versions of PHP (5.2.x) by removing the anonymous function.

        The newer version 1.1.7 should be working fine now.

  7. Hello!
    I downloaded wp wrapper today, with high hopes. Unfortunately, I did not get to see if it would work for my purposes as it put an advertisement for Apple products on my front page. Deleted the plugin, advertisement gone. Is this intentional? If not, and it is fixable, I would love to use this product.
    Thanks!

    1. Thanks for feedback. It wasn’t an ad :) I have added apple.com as default web address for wrapper. You have to go to settings > wp wrapper and enter your settings and it will show yours :)

      I hope it’s clear now. I will remove it in next release too for avoiding confusion. Thanks for the tip though :)

  8. When I set the wrapper height to 100% I only get a short box. The page it’s loading is a little slow, it’s a moodle installation. Maybe the wrapper needs to let the page load before it sets its height so slow pages get the full height shown without scroll bars?

  9. Вoes not work:((

    Warning: Declaration of Walker_PageDropdownnew::start_el(&$output, $page, $depth, $args) should be compatible with Walker::start_el(&$output, $object, $depth = 0, $args = Array, $current_object_id = 0) in /home/nspcompa/nsp-company.ru/www/wp-content/plugins/wp-wrapper-master/wp-wrapper.php on line 33

  10. I solved the problem)

    Warning: Declaration of Walker_PageDropdownnew::start_el(&$output, $page, $depth, $args) should be compatible with Walker::start_el(&$output, $object, $depth = 0, $args = Array, $current_object_id = 0) in /home/nspcompa/nsp-company.ru/www/wp-content/plugins/wp-wrapper-master/wp-wrapper.php on line 33

    , the solution is simply to change the arguments to function introduction (& $ output, $ page, $ depth, $ ARGS) to (& $ output, $ object, $ depth = 0, $ args = Array, $ current_object_id = 0) Thank you for Good quality and plug

    1. Yes we can use iframes in WordPress.

      Regarding the part of including the other url in your file, that’s also possible. Provided that you know what you need to do in file.php to show and utilize that url.

      Please clarify your requirement so that I can explain it further.

  11. How can i relocate the place where the wrapper shows, i wanted it below the slider, it goes to the bottom of the page before the footer

  12. Hello,

    I just found your plugin. Great idea. However, I’m not able to get it to work. I get an error saying 99pledges.com refused to connect.. I’m trying to wrap

    1. The issue is with 99pledges website probably. Either their server is slow or down, or they refuse connections from frames.
      Please try entering any other domain name to see if it works.

Leave a Reply to Doug Cancel reply

Your email address will not be published.